वर्डप्रेस 5.6.1 पोस्ट और पेज विंडोज में बग का परिचय देता है

वर्डप्रेस 5.6.1, जिसे कई साइटों ने ऑटो-अपडेट किया है, ने एक बग पेश किया है जिससे पोस्ट को सहेजना मुश्किल हो जाता है। समस्या को हल करने के लिए एक अस्थायी पैच बनाया गया है लेकिन यह समस्या को हल करने के लिए एक आधिकारिक अद्यतन नहीं है।

आपके द्वारा किए गए परिवर्तन सहेजे नहीं जा सकते

वर्डप्रेस के नवीनतम संस्करण में एक बग पेश किया गया, संस्करण 5.6.1 पोस्ट को सहेजे जाने या न होने पर भी, नेविगेट करने का प्रयास करते समय पॉप अप के लिए अलर्ट का कारण बनता है।

बग की सूचना मिली थी WordPress सपोर्ट पेज में:

“मुझे पॉप अप मिल रहा है” साइट छोड़ दो? आपके द्वारा किए गए परिवर्तन सहेजे नहीं जा सकते हैं। हर समय, यदि मैं एक पृष्ठ बदलता हूं या नहीं, और यदि मैं पृष्ठ को सहेज (प्रकाशित या अपडेट) करता हूं या नहीं।

आज सुबह 5.6.1 अपग्रेड के बाद यह शुरू हुआ। मेरे पास 2 साइटें हैं, 2 अलग-अलग विषयों के साथ, दोनों क्लासिक संपादक 1.6 के साथ हैं और यह दोनों पर समान व्यवहार करता है।

यह क्रोम में ऐसा करता है, यह फ़ायरफ़ॉक्स में नहीं करता है। ”

विज्ञापन

नीचे पढ़ना जारी रखें

तथ्य यह है कि यह फ़ायरफ़ॉक्स में नहीं होता है दिलचस्प है क्योंकि फ़ायरफ़ॉक्स क्रोम में क्रोम से अलग तरीके से अनलोड घटना के कुछ पहलुओं को संभालता है जिसमें कुछ विशेषताओं का अभाव है।

एक उदाहरण के रूप में, जब इवेंट से पहले सक्रिय किया गया हो तो घटना के साथ सक्रिय किया गया ।preventDefault () फ़ायरफ़ॉक्स के साथ काम करता है लेकिन क्रोम के साथ नहीं। https://developer.mozilla.org/en-US/docs/Web/API/Window/beforeunn_vent

मैं यह नहीं कह रहा हूं कि यह मुद्दा है। बस इंगित करता है कि फ़ायरफ़ॉक्स कुछ सुविधाओं का समर्थन करता है जो क्रोम नहीं करता है

WordPress संपादन विंडो में इवेंट बग को अनलोड करें?

यह नोटिस एक “अनलोड घटना” कहलाता है, जो एक चेतावनी को ट्रिगर करता है जब एक प्रकाशक खिड़की से दूर नेविगेट करने की कोशिश करता है, आमतौर पर जब कुछ पूर्ववत होता है।

ट्रिगर किया गया सटीक चेतावनी संदेश है:

विज्ञापन

नीचे पढ़ना जारी रखें

“साइट छोड़ दो? आपके द्वारा किए गए परिवर्तन सहेजे नहीं जा सकते हैं। ”

बग अपने आप को पोस्ट और पेज दोनों में प्रकट करता है। लेकिन कुछ प्रकाशकों ने बताया है कि बग केवल पृष्ठ सामग्री को संपादित करते समय मौजूद होता है और पोस्ट सामग्री को संपादित करते समय ठीक काम करता है।

कई रिपोर्टों के अनुसार टिनी MCE और एडवांस्ड कस्टम फील्ड्स जैसे संबंधित प्लगइन्स को संपादित करके बग को ट्रिगर किया जा सकता है। उन प्लगइन्स को बंद करने से स्पॉइंग से अनलोड संदेश बंद हो जाता है।

एक प्रकाशक ने प्राइवेट में सूचना दी उन्नत वर्डप्रेस फेसबुक समूह उन्नत कस्टम फ़ील्ड्स प्लगइन को बंद करने से स्पॉनिंग से चेतावनी बंद हो गई।

लेकिन समस्या खुद प्लगइन्स के साथ नहीं है। समस्या वर्डप्रेस कोर के भीतर ही प्रतीत होती है जो समस्या को विभिन्न संपादन संबंधित विंडोज़ में प्रकट करने का कारण बन रही है।

एक प्रकाशक ने राहत की सूचना दी गुटेनबर्ग संपादन वातावरण को चालू करके:

“क्या आप इस साइट को छोड़ना चाहते हैं? आपके द्वारा किए गए परिवर्तनों को सहेजा नहीं जा सकता है ”क्लासिक संपादक का उपयोग करते समय 5.6.1 अद्यतन के बाद अद्यतन पृष्ठ (लेकिन पोस्ट नहीं) छोड़ने पर चेतावनी। … जब गुटेनबर्ग को वापस चालू किया जाता है, तो चला जाता है। “

एक और प्रकाशक ने नोट किया उस WordPress संपादन से संबंधित प्लगइन्स बग को ट्रिगर करना चाहते थे:

“अपडेट: ऐसा लगता है कि उपयोगकर्ता को बदलाव करने से पहले पूरी तरह से लोड होने के लिए टिनीएमसीई का इंतजार करना पड़ता है, अन्यथा स्क्रिप्ट उसके बदलाव को ध्यान में नहीं रखती है।

एक अच्छा दृश्य संकेत, टूलबार की ड्रॉपडाउन है, जो एक बार संपादक द्वारा सही ढंग से आरंभ किए जाने के बाद फैलता है। ”

एक उपयोगकर्ता ने एक पूर्वाभ्यास का एक वीडियो अपलोड किया जिसमें दिखाया गया है कि बग को कैसे पैदा किया जाता है। वीडियो में प्रकाशक संपादन विंडो को संपादित करने और प्रवेश करने के लिए एक दस्तावेज चुनता है।

विज्ञापन

नीचे पढ़ना जारी रखें

प्रकाशक अगले पेज को बचाने के लिए अपडेट बटन दबाता है। वे अगले संपादन विंडो से दूर नेविगेट करने के लिए एक लिंक पर क्लिक करते हैं।

लेकिन यह अधिनियम अनलोड चेतावनी संदेश को फैलाने का कारण बनता है।

नीचे मूवी का एक एनिमेटेड जिफ़ है जो बग के चलने को दिखाते हुए अपलोड किया गया था:

वर्डप्रेस का स्क्रीनशॉट एनीमेशन 5.6.1 विंडो बग का संपादन

वर्डप्रेस 5.6.1 का GIF एनीमेशन विंडो बग संपादन

अस्थायी समाधान पोस्ट किया गया है

वर्डप्रेस पर एक पैच पोस्ट किया गया है, लेकिन यह आधिकारिक फिक्स नहीं है।

विज्ञापन

नीचे पढ़ना जारी रखें

यह पैच का संस्करण पूरी तरह कार्यात्मक है। यह कोड है जिसे फ़ंक्शन.php फ़ाइल में डाला जाना चाहिए।

वहाँ है एक और पैच यह साझा किया गया था जो एक अतिरिक्त मुद्दे को संबोधित करता है लेकिन यह पूरी तरह से परीक्षण नहीं किया गया है।

वर्डप्रेस 5.6.1 बग को सहेजे नहीं बनाया गया परिवर्तन

यदि समस्या आपके वर्कफ़्लो में बाधा डाल रही है, तो ऐसे चरण हैं जो उठाए जा सकते हैं। एक अनुशंसित कदम यह सुनिश्चित करने के लिए प्रतीक्षा करने के लिए हो सकता है कि संपादन से संबंधित सभी प्लगइन्स पूरी तरह से भरी हुई हैं। अन्य क्रियाओं में संपादन संबंधित प्लगइन्स को अक्षम करना या गुटेनबर्ग को चालू करना शामिल है।

एक पैच है जिसे फ़ंक्शन पर लागू किया जा सकता है। एफपी और अंतिम रूप से एक आधिकारिक पैच का इंतजार कर सकता है।

नागरिकताएँ

वर्डप्रेस सपोर्ट पेज डिस्कशन
आपके द्वारा किए गए परिवर्तन सहेजे नहीं जा सकते

विज्ञापन

नीचे पढ़ना जारी रखें

आधिकारिक वर्डप्रेस बग रिपोर्ट पृष्ठ
“साइट छोड़ दो? WP 5.6.1 अद्यतन के बाद आपके द्वारा किए गए परिवर्तन कस्टम टैक्सोनॉमी पेज पर सहेजे नहीं जा सकते ”

Related Posts

Leave a Reply

Your email address will not be published. Required fields are marked *