वर्डप्रेस गुटेनबर्ग 10.2 कारण घातक त्रुटियाँ

वर्डप्रेस प्रकाशकों को पता चल रहा है कि गुटेनबर्ग 10.2 (17 मार्च, 2021 को जारी) एक वर्डप्रेस असंगतता के कारण “घातक त्रुटियां” पैदा कर रहा है। एक प्रकाशक ने सुझाव दिया कि गुटेनबर्ग ऑटोपाडेट्स एक संगतता जांच करें और एक चेतावनी को ट्रिगर करें यदि असंगति मौजूद है।

वर्डप्रेस गुटेनबर्ग

गुटेनबर्ग एक विज़ुअल वर्डप्रेस साइट एडिटर है जो कि मूल रूप से वर्डप्रेस कोर के भीतर वेबसाइटों को कैसे बनाया गया था, से एक क्रांतिकारी प्रस्थान का प्रतिनिधित्व करता है।

यह प्रकाशकों को ब्लॉकों के ग्राफिक यूजर इंटरफेस का उपयोग करके साइट बनाने की अनुमति देता है। उदाहरण के लिए, एक वेब पेज को पृष्ठ के शीर्ष (हेडर), सामग्री क्षेत्र, साइडबार, आदि का प्रतिनिधित्व करने वाले ब्लॉक के रूप में देखा जा सकता है।

विज्ञापन

नीचे पढ़ना जारी रखें

गुटेनबर्ग अभी समाप्त नहीं हुआ है, पूर्ण साइट संपादन क्षमता अभी भी रास्ते में है। तो स्वाभाविक रूप से अभी तक एक परिपक्व प्रौद्योगिकी बग का पूर्वानुमान नहीं है, अगर अपेक्षित नहीं है।

गुटेनबर्ग 10.2 घातक त्रुटि

एडवांस्ड वर्डप्रेस फेसबुक ग्रुप के एक सदस्य ने गुटेनबर्ग 10.2 को अपडेट करते समय सामने आई एक घातक त्रुटि के दस्तावेज पर चर्चा शुरू की।

पोस्ट ने कहा कि वर्डप्रेस संस्करण 5.6 में घातक त्रुटि प्रकट हुई। यह भी कहा गया था कि त्रुटि पर एक GitHub पोस्ट ने नोट किया कि Gutenberg 10.2 WP 5.5 के साथ संगत नहीं है।

वर्डप्रेस और गुटेनबर्ग रिलीज टाइमलाइन

वर्डप्रेस 5.7 को 9 मार्च, 2021 को जारी किया गया था।

गुटेनबर्ग 10.2 साइट के संपादक को एक हफ्ते बाद 17 मार्च, 2021 को थोड़ी देर में रिहा कर दिया गया।

गुटेनबर्ग साइट प्रकाशक जिन्होंने वर्डप्रेस 5.7 पर अपडेट किया और फिर गुटेनबर्ग 10.2 पर अपडेट किया गया, उन्हें इस त्रुटि को नहीं देखना चाहिए।

विज्ञापन

नीचे पढ़ना जारी रखें

हालांकि प्रकाशक जो गुटेनबर्ग 10.2 पर अपडेट हुए, लेकिन वर्डप्रेस खुद को घातक त्रुटि का अनुभव नहीं कर सकता है।

घातक त्रुटि विशेष रूप से उन प्रकाशकों के लिए होती है जो अपने गुटेनबर्ग इंस्टॉलेशन को स्वचालित रूप से अपडेट (स्वचालित) करने के लिए सेट होते हैं, लेकिन स्वयं वर्डप्रेस को स्वतः सेट करने के लिए सेट नहीं होते हैं।

अधिकारी में एक त्रुटि नोट की गई थी गुटेनबर्ग वर्डप्रेस समर्थन मंचों लेकिन इस लेखन के समय कोई अनुवर्ती नहीं था।

घातक दोष मुद्दे को भी आधिकारिक तौर पर प्रलेखित किया गया था गुटेनबर्ग GitHub पेज

GitHub रिपोर्ट से:

“10.2.0 पर अपडेट करने के बाद मुझे प्लगइन के साथ एक तकनीकी समस्या के बारे में एक ईमेल मिला:

E_ERROR प्रकार की एक त्रुटि फ़ाइल की लाइन 59 में हुई थी … मैं ftp के माध्यम से प्लगइन को डी-एक्टिवेट करने में सक्षम था। अब मैं इसे तब तक सक्रिय नहीं करना चाहता जब तक कि मुझे पता नहीं है कि इसे संबोधित नहीं किया गया है। ”

एक अन्य व्यक्ति ने पोस्ट किया कि उन्होंने एक ही चीज़ पर ध्यान दिया और एक स्क्रीनशॉट पोस्ट किया:

वर्डप्रेस गुटेनबर्ग घातक त्रुटिवर्डप्रेस गुटेनबर्ग घातक त्रुटि का स्क्रीनशॉट

स्क्रीनशॉट प्रकाशित करने वाले उपयोगकर्ता ने इसके साथ:

“मैं वर्डप्रेस 5.6 चला रहा था। 5.7 में अपग्रेड होने के बाद, सब कुछ उम्मीद के मुताबिक काम करने लगा। ”

मूल GitHub पोस्ट को शुरू करने वाले व्यक्ति ने पुष्टि की कि यह उनका मुद्दा था।

विज्ञापन

नीचे पढ़ना जारी रखें

“मुझे 5.7 के बारे में बताने के लिए धन्यवाद। मैंने WP को अपडेट नहीं किया था, अब मैं गुटेनबर्ग को फिर से सक्रिय कर सकता हूं। “

गुटेनबर्ग 10.2 वर्डप्रेस के पुराने संस्करणों के साथ असंगत

एक और गिटहब गुटेनबर्ग की रिपोर्ट यह रेखांकित किया गया कि गुटेनबर्ग 10.2 ने वर्डप्रेस के पुराने संस्करणों में घातक त्रुटियों का कारण बना।

वर्डप्रेस संस्करण 5.5.3 का उपयोग करने वाले एक प्रकाशक ने भी एक घातक त्रुटि की सूचना दी जिससे दुर्घटना हुई।

समस्या की रिपोर्ट करने वाले व्यक्ति ने पुष्टि की कि यह गुटेनबर्ग 10.2 के लिए विशिष्ट था, और कहा:

“मैंने Gutenberg प्लगइन 10.2.0 को निष्क्रिय कर दिया है। जब मैंने प्लगइन को फिर से सक्रिय करने की कोशिश की तो घातक त्रुटि वापस आ गई।

Fatal error: Uncaught Error: Class 'WP_Block_Supports' not found in..."

उस व्यक्ति ने एक उपयोगी अवलोकन और सुझाव दिया कि गुटेनबर्ग 10.2 को WP 5.7 से कम वर्डप्रेस संस्करणों पर अपडेट (या ऑटूपडेट) करने की अनुमति नहीं दी जानी चाहिए।

“यह एक पुराने WP साइट पर Gutenberg प्लगइन को स्वचालित करने के लिए संभव नहीं होना चाहिए। परिणाम के रूप में एक घातक त्रुटि बनाने के लिए लगता है। चूंकि इस समस्या में बहुत सी साइटें आ सकती हैं।

विज्ञापन

नीचे पढ़ना जारी रखें

यह समस्या का एक अच्छा समाधान है! यदि गुटेनबर्ग 10.2 और वर्डप्रेस के पुराने संस्करणों के बीच एक ज्ञात असंगति मौजूद है, तो यह समझ में आता है कि उन स्थितियों में ऑटोपेडेट्स एक असंगतता की चेतावनी को रोक देगा और उत्पन्न करेगा।

गुटेनबर्ग साइट के संपादक, जो वर्डप्रेस के एक संस्करण के साथ प्रकाशित कर रहे हैं, जो कि WP 5.7 से अधिक पुराना है, इसे गुटेनबर्ग 10.2 में अपडेट करने से पहले नवीनतम संस्करण में अपडेट करने के लिए विवेकपूर्ण माना जा सकता है।

उद्धरण

गिटहब:
गुटेनबर्ग 10.2.0 बंद एक घातक त्रुटि # 29977

गिटहब:
गुटेनबर्ग प्लगिन में घातक त्रुटि 10.2.0 # 29972

फेसबुक: उन्नत वर्डप्रेस समूह (देखने के लिए आवश्यक समूह सदस्यता)
FYI करें, नवीनतम गुटेनबर्ग प्लगइन 10.2 अपडेट एक घातक त्रुटि का कारण होगा

Related Posts

Leave a Reply

Your email address will not be published. Required fields are marked *